Este sitio es propiedad de cookies de terceros.
Si usted continúa con nosotros, entendemos que acepta nuestro uso de cookies.

  • Este sitio usa cookies. Para continuar usando este sitio, debes aceptar nuestro uso de cookies. Más información.
Home

Velocidad de red del deco

erdebugger

Usuario Activo
Amigo OpenSPA
Forero
#1
Si cuando transfieres archivos hacia el deco te das cuenta de que va excesivamente lento seguramente te pase que la tarjeta de red de tu receptor esté configurada a 10 Mbps

Para configurarla correctamente a 100 Mbps solo tienes que hacer lo siguiente desde un terminal Telnet:

ethtool -s eth0 speed 100 duplex full

Si quieres que esta configuración se active aunque reinicies el deco, tendrás que crear un archivo en la carpeta
/etc/network/if-up.d llamado por ejemplo cienmegas con el siguiente contenido:

#!/bin/sh
ethtool -s eth0 speed 100 duplex full

Si estás haciendo este nuevo fichero en Windows, ojo, porque entonces antes de grabarlo necesitarás usar la función EOL Conversion del Notepad++ y seleccionar Convertir a formato UNIX.

Esto último es debido a que Windows añade al final de las líneas de un fichero de texto los caracteres CR y LF y sin embargo LINUX solo necesita LF. Por esa razón es importante convertir el fichero al formato UNIX antes de pasar el archivo al deco.

Espero que os sea útil. Yo lo he probado en un AZBOX Me y me funciona perfectamente.
 

darkmantk

OpenSpa Team
Miembro del equipo
#4
Pero en los azbox vienen capada la velocidad ¿no? ¿Con esto se solucionaría? O cómo se ha hablado otras veces el capado es por hardware
No, los azbox vienen tambien configurado a 100 Mbps.

Lo hemos mirado y remirado morser y yo y siempre se configura en 100.

Otra cosa es el capado que tiene el bus del deco que es a nivel de hardware y no de software.
 

erdebugger

Usuario Activo
Amigo OpenSPA
Forero
#5
Es tan fácil como comprobarlo por vosotros mismos.

Si sale menos de 100 en la velocidad actual... hacéis lo del mensaje anterior, si no, pues mejor y está todo ok sin hacer nada.

Por cierto, para comprobar la velocidad a la que tienes configurada la tarjeta de red en el deco, desde telnet:

ethtool eth0

y saldrá algo así:

root@azboxme:/etc# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 3
Transceiver: internal
Auto-negotiation: on
Link detected: yes

Si donde pone Speed os sale 10 en vez de 100, haced lo que describo en el post anterior.

Saludos.
 

goyha2007

Usuario
Fan de OpenSPA
#6
A mi como máximo me transfiere los archivos a 2 Mb con Filezilla ¿se puede incrementar la velocidad? O esa velocidad es normal???
 

rusoalicia

Super Mod
Miembro del equipo
Moderador OpenSPA
#7
Ya se ha hablado de esto muchas veces en el foro, esa velocidad es normal ya que los azbox tienen capado por hardware el adaptador de red.
 

erdebugger

Usuario Activo
Amigo OpenSPA
Forero
#9
Insisto en que se pueden transferir archivos a 100 megabits haciendo lo que expongo en post anteriores. Con FileZilla pasan a 10 megabytes por segundo limpios. Transferir a 2 son 5 veces menos y eso es porque tu azbox está configurado por defecto a 10 megabits

Enviado desde mi HUAWEI GRA-L09 mediante Tapatalk
 

goyha2007

Usuario
Fan de OpenSPA
#10
Erdebugger he puesto por telnet lo que dices y me sale lo mismo que pones en el post, mi velocidad de transferencia es de 2 mb con el programa filezilla y con suerte logro pasar archivos de mas de 4 gb, normalmente me da transferencia fallida. Desconozco si hay algún programa mejor y mas rapido