Este sitio es propiedad de cookies de terceros.
Si usted continúa con nosotros, entendemos que acepta nuestro uso de cookies.

  • Este sitio usa cookies. Para continuar usando este sitio, debes aceptar nuestro uso de cookies. Más información.
Home

Picons de canales no visibles en la lista de Openwebif.

daviddrf

Usuario Destacado
Loco por OpenSPA
#1
Indicar el modelo de deco/receptor que tienes: Vu+ Duo2.

Versión de OpenSpa: 7.3.011.

Descripción del fallo: en Openwebif no aparece ningún picon de ningún canal en la lista tal y como se puede ver a continuación:



Características especiales: dichos picons los puedo ver perfectamente en la lista de canales del deco que aparece en la propia skin además de en la infobar, sin embargo no en Openwebif. La casilla siguiente sí está marcada:



Se adjunta Crash-log: No .

PD: sería algo parecido a lo ocurrido aquí, solo que yo ya he limpiado la caché del navegador y demás pero sigue ocurriéndome:
https://openspa.info/threads/¿ver-picon-en-lista-de-canales-openwebif.41052/page-2
Saludos.
 
Última edición:

daviddrf

Usuario Destacado
Loco por OpenSPA
#2
He probado también a cambiar de diseño o estilo en Openwebif, del viejo por el nuevo y viceversa pero sigue sin funcionar me temo.
 
Última edición:

daviddrf

Usuario Destacado
Loco por OpenSPA
#3
Por otro lado también he probado a desmarcar la casilla de "Mostrar Picon en la lista de canales" en la configuración de Openwebif y volver a marcarla pero tras esto siguen sin mostrarse los picons en Openwebif.
 

morser

OpenSpa Team
Miembro del equipo
#4
Y donde tienes los picons? Enigma busca los picons en un monton de carpetas diferentes, incluso le puedes poner tu una carpeta personalizada, pero el openwebif creo que solo busca en unas carpetas concretas. A mi por ejemplo, tampoco me salen porque los tengo en varias carpetas que no son las estandar. El tema es que el openwebif no es nuestro y tendrian que arreglarlo los desarrolladores del mismo.
 

evox

OpenSpa Team
Miembro del equipo
#6
No hay tal fallo, probado en VU+ Duo2 con Openspa 7.3.011 y sin problemas como se puede apreciar.

picons.jpg

Salu2.
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#7
Hola chicos. Gracias en primer lugar por vuestras respuestas. En el primer mensaje que edité para adaptarlo a la plantilla había indicado que la ruta de mis picons la modifiqué a /picon (en la raíz de la memoria flash) en lugar del tradicional directorio /usr/share/enigma2/picon (este último me parece un poco...profundo). Tras la edición con la plantilla ya cubierta me olvidé de volver a mencionarlo, perdón. No se me había ocurrido que el motivo por el cual Openwebif no mostrase los picons pudiera ser el cambio por mi parte de la ruta o directorio donde se alojan los mismos, así que he probado a volver a alojar los picons en la ruta por defecto /usr/share/enigma2/picon y tras el reinicio...sorpresa:



Vuelven a ser visibles los picons, de lo cual deduzco que efectivamente se trata de un "bug" del plugin Openwebif y no de la imagen Openspa al cambiar la ruta estándar de los picons como bien comenta morser. Gracias por la aclaración y disculpad las molestias ¿Alguno de vosotros sabe cómo se podría en Openwebif modificar esto? Un saludo.
 

fogo

Usuario Destacado
Vip OpenSPA
#8
tanto E2 como el OWIF leen si metes la carpeta picon en el raiz...por eso lo ves en E2.....lo de que no los veas en el OWIF ¿parcheas algún python de este plugin para streaming?...¿navegador limpieza completa cookies caché etc etc con su refresco después?.....por que funcionar funcionan en ese directorio y se ven en dicho plugin sin ningún tipo de problemas.
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#9
tanto E2 como el OWIF leen si metes la carpeta picon en el raiz...por eso lo ves en E2.....lo de que no los veas en el OWIF ¿parcheas algún python de este plugin para streaming?...¿navegador limpieza completa cookies caché etc etc con su refresco después?.....por que funcionar funcionan en ese directorio y se ven en dicho plugin sin ningún tipo de problemas.
Hola fogo ¿Tú con los picons en la carpeta /picon en la raíz de la flash puedes verlos todos por Openwebif? Saludos.
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#11
así es, no hay problema alguno.
Entendido, así lo tenía yo en Openspa 7.2.x y sin problema efectivamente. Lo he intentado con varios navegadores diferentes (Firefox, Chrome y hasta Tor Browser) pero sin éxito. Es verdad que he realizado cambios en plugin.py de \usr\lib\enigma2\python\Plugins\Extensions\OpenWebif para poder cambiar el puerto de streaming según las instrucciones que algún forero me enseñó y que expliqué en su día en el mensaje #30 del siguiente hilo y que por cierto veo que han borrado xD:

https://openspa.info/threads/puertos-en-openwebif-y-streaming.31340/page-2

Por otro lado comentar que si por el contrario la solución fuese dejar los picons en la ruta que viene por defecto (/usr/share/enigma2/picon) para que así Openwebif los "cachee" correctamente por mi parte no habría problema, aunque sí me parece curioso que en una ruta sí vayan y en otra no...

Saludos y gracias nuevamente por la ayuda.
 

fogo

Usuario Destacado
Vip OpenSPA
#12
No es curioso, estas parcheando un codigo fuente de un plugin que se actualiza muchísimo.....y en el pues estas metiendo codigo distinto que aún a ti te valga para tus cosas pues puedes romper parte de las acciones del plugin actualizado.
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#13
No es curioso, estas parcheando un codigo fuente de un plugin que se actualiza muchísimo.....y en el pues estas metiendo codigo distinto que aún a ti te valga para tus cosas pues puedes romper parte de las acciones del plugin actualizado.
Yo entiendo lo que me dices fogo, de todos modos y a modo de curiosidad probaré en otro deco la imagen actualizada de Openspa 7.3.011 sin modificaciones por mi parte en el plugin.py de Openwebif y os comento a ver qué ocurre...Saludos y gracias nuevamente por la ayuda.
 

morser

OpenSpa Team
Miembro del equipo
#14
Como he comentado, el openwebif no busca los picons en las mismas carpetas que Enigma2.

- Enigma2 puede utilizar varias carpetas a la vez, es decir, puedes tener algunos picons en una ruta y otros en otra ruta diferente y localizar el picon en la que este. Openwebif solo utiliza una unica carpeta a la vez
- Enigma2 permite ademas configurar una ruta de picons personalizada, Openwebif no.
- Para Enigma2 se pueden usar las siguientes carpetas:
"/picon",
"/XPicons",
"/XPicons/picon",
"/picon/XPicons",
"/",
Y las localizara en todas las rutas que se tengan montadas. Ademas tambien se podra usar
"/usr/share/enigma2/picon" y la ruta personalizada en configuracion.

- Para Openwebif solo se pueden usar las carpetas picon o owipicon en las siguientes rutas:
"/media/cf/",
"/media/mmc/",
"/media/usb/",
"/media/hdd/",
"/usr/share/enigma2/",
"/"
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#16
Como he comentado, el openwebif no busca los picons en las mismas carpetas que Enigma2.

- Enigma2 puede utilizar varias carpetas a la vez, es decir, puedes tener algunos picons en una ruta y otros en otra ruta diferente y localizar el picon en la que este. Openwebif solo utiliza una unica carpeta a la vez
- Enigma2 permite ademas configurar una ruta de picons personalizada, Openwebif no.
- Para Enigma2 se pueden usar las siguientes carpetas:
"/picon",
"/XPicons",
"/XPicons/picon",
"/picon/XPicons",
"/",
Y las localizara en todas las rutas que se tengan montadas. Ademas tambien se podra usar
"/usr/share/enigma2/picon" y la ruta personalizada en configuracion.

- Para Openwebif solo se pueden usar las carpetas picon o owipicon en las siguientes rutas:
"/media/cf/",
"/media/mmc/",
"/media/usb/",
"/media/hdd/",
"/usr/share/enigma2/",
"/"
Mil gracias morser, queda entonces perfectamente claro el porqué de este comportamiento ya que con los picons metidos en la carpeta "/picon" en la raíz de la flash no aparecerán por Openwebif pero sí si, por ejemplo, estuvieran éstos alojados en la ruta por defecto de Enigma2 ("/usr/share/enigma2/picon "). Saludos.
 

fogo

Usuario Destacado
Vip OpenSPA
#17
es que lo pone morser en las siguientes rutas:
"/"

esto y meterlos en el raiz es lo mismo...yo si muevo mis picons al raiz en el openwebif sigo viendolos sin problemas.
 

daviddrf

Usuario Destacado
Loco por OpenSPA
#18
es que lo pone morser en las siguientes rutas:
"/"

esto y meterlos en el raiz es lo mismo...yo si muevo mis picons al raiz en el openwebif sigo viendolos sin problemas.
Ya, si os he entendido correctamente a ambos fogo, pero mira, Vu+ Zero flasheado hace escasos minutos con Openspa 7.3.011 sin ninguna modificación en Openwebif con los picons en la carpeta "/picon" de la raíz de la flash:

Aquí los picons perfectamente visibles en la lista de canales de la skin MyMetrix:


Aquí la ruta de los picons visible a través de SMB desde Windows:


Aquí la casilla para mostrar los picons en Openwebif:


Y por último cómo no se ven los picons en Openwebif:


Los picons que yo empleo son estos de picons.eu:

https://github.com/picons/picons/re...t.on.transparent_2019-08-07--18-58-25_all.ipk

Espero no estar cometiendo ningún error al respecto, aunque sinceramente da igual ya que metiendo los picons en "/usr/share/enigma2/picon" se ven perfectamente por Openwebif como he comentado anteriormente; saludos y gracias otra vez.
 

fogo

Usuario Destacado
Vip OpenSPA
#19
yo uso tu mismo OpenWebif ya que esto es un plugin común del OE-A, te aseguro que la ruta de picon funciona en el raiz, si miramos un python de este plugin el "services" te darías cuenta de lo que te quiero hacer explicar, no se como tienes la lista de canales, la EPG, o no se la verdad pero por las imágenes que pones es que no solo te faltan los picons sino la información EPG no se te muestra, aqui te dejo lo que yo veo con ellos en el raiz:

 

daviddrf

Usuario Destacado
Loco por OpenSPA
#20
yo uso tu mismo OpenWebif ya que esto es un plugin común del OE-A, te aseguro que la ruta de picon funciona en el raiz, si miramos un python de este plugin el "services" te darías cuenta de lo que te quiero hacer explicar, no se como tienes la lista de canales, la EPG, o no se la verdad pero por las imágenes que pones es que no solo te faltan los picons sino la información EPG no se te muestra, aqui te dejo lo que yo veo con ellos en el raiz:

Sí, a ti se te ven perfectamente como ya me habías mostrado con anterioridad. En cuanto a lo de la EPG...puede que vayan por ahí los tiros ya que yo no empleo efectivamente MHW2 integrado en Openspa por defecto para la descarga de EPG si no EPG Import con una lista XMLtv...Saludos y gracias nuevamente por tu ayuda.