Home

Bug general No carga driver wifi por falta de memoria

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Receptor: Gigablue UHD Trio 4k
Versión de Openspa: 7.4.007
Descripción del fallo: Tengo un adaptador wifi con chip 8811cu. Según he leído le vale el driver rt8821cu. Lo instalo, reinicio y sigue sin detectarlo. He entrado por terminal y da un problema de memoria insuficiente (vmalloc)
Características especiales: No creo que tener nada especial
Crashlog: No tengo un crash log porque no da un crash log. Tengo la información que devuelve el "lsusb", el "cat /proc/meminfo" y el "dmesg". Los he puesto en https://pastebin.com/zRw0ubMy

He leído que podía ampliar la memoria VmallocTotal tocando los argumentos del kernel pero no sé si puedo hacerlo yo.
Si me he equivocado de hilo, por favor, movedlo.

Gracias
 

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Buenas noches. Acabo de actualizar a la imagen 7.4.008 y el problema persiste.

¿Me podríais decir solamente si yo puedo hacer algo para solucionarlo o tengo que esperar a una nueva imagen?

Gracias de antemano
 

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Buenas noticias: con la actualización de firmware (7.4.009) ya funciona. He instalado el plugin driver 88x1cu y reiniciado y lo ha reconocido al instante. Ya está configurado y funcionando.
¡Gracias!
Receptor: Gigablue UHD Trio 4k
Versión de Openspa: 7.4.007
Descripción del fallo: Tengo un adaptador wifi con chip 8811cu. Según he leído le vale el driver rt8821cu. Lo instalo, reinicio y sigue sin detectarlo. He entrado por terminal y da un problema de memoria insuficiente (vmalloc)
Características especiales: No creo que tener nada especial
Crashlog: No tengo un crash log porque no da un crash log. Tengo la información que devuelve el "lsusb", el "cat /proc/meminfo" y el "dmesg". Los he puesto en https://pastebin.com/zRw0ubMy

He leído que podía ampliar la memoria VmallocTotal tocando los argumentos del kernel pero no sé si puedo hacerlo yo.
Si me he equivocado de hilo, por favor, movedlo.

Gracias
 

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Receptor: Gigablue UHD Trio 4k
Versión de Openspa: 7.4.007
Descripción del fallo: Tengo un adaptador wifi con chip 8811cu. Según he leído le vale el driver rt8821cu. Lo instalo, reinicio y sigue sin detectarlo. He entrado por terminal y da un problema de memoria insuficiente (vmalloc)
Características especiales: No creo que tener nada especial
Crashlog: No tengo un crash log porque no da un crash log. Tengo la información que devuelve el "lsusb", el "cat /proc/meminfo" y el "dmesg". Los he puesto en https://pastebin.com/zRw0ubMy

He leído que podía ampliar la memoria VmallocTotal tocando los argumentos del kernel pero no sé si puedo hacerlo yo.
Si me he equivocado de hilo, por favor, movedlo.

Gracias
Hola,
Se ha vuelto a reproducir este error en la versión 8.0.001

Hasta la fecha no había vuelto a fallar desde que en la versión 7.4.009 se arreglara. Tan solo lo que me ocurría era que después de la actualización tenía que volver a cargar el driver desde la lista de plugins porque en el primer inicio no funcionaba el adaptador. Pero le ponía uno de tipo g, instalaba los plugins otra vez y volvía a poner el adaptador de tipo ac.

Pero en esta ocasión, he instalado el plugin de siempre pero no lo carga, como me pasaba con la versión 7.4.007 Y el adaptador sigue funcionando correctamente en la versión 7.5.005
¿Sabeis si puedo hacer algo al respecto para arreglarlo? (A parte de cambiar de adaptador wifi jojojo)

Por si podéis tenerlo en cuenta para la siguiente versión.

Gracias de antemano
 

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Bueno, así a bote pronto parece que en la 8.0.002 tampoco funciona el adaptador. No carga el driver 8821cu. He visto que viene uno instalado el, 8822algo pero tampoco me lo reconoce en el adaptador
 

evox

OpenSpa Team
Miembro del equipo
Moderador OpenSPA
2 Mar 2009
5.730
4.047
0
Bueno, así a bote pronto parece que en la 8.0.002 tampoco funciona el adaptador. No carga el driver 8821cu. He visto que viene uno instalado el, 8822algo pero tampoco me lo reconoce en el adaptador
Haz una cosa, vete a plugins luego borrar plugins (boton rojo) y en drivers desistalas los que no uses pero solo adaptadores usb wifi, reinicias receptor y miras si te carga el tuyo, si sigue fallando prueba a instalarte el plugin swapmanager y create un swapfile de 128mb en un pendrive haber si asi desahoga la ram y no casca, pero me da que ese driver no esta muy al dia y nosotros no podemos meterle mano, los drivers son cosa de OE-A.

Salu2.
 

Paquete

Usuario
Amigo OpenSPA
Forero
26 Nov 2019
11
2
0
36
Hola evox, ante todo quiero darte las gracias por tu ayuda pero sobre todo pedirte perdón por no contestarte antes.
Empecé a hacer, en la versión 8.0.002, las pruebas que me comentabas. Hice lo que me sugerías de borrar plugins pero no funcionó. Como me desanimé mucho y en la versión 7.5.005 funcionaba pospuse la prueba del swapfile y acabé "olvidándome" de ella.
Luego se liberó la versión 8.0.003 y probé a instalarla. Como siempre que hago un cambio de versión, tengo que volver a cargar todos los plugins porque, aunque la copia de seguridad los tiene, no los restaura (creo que es porque nada más arrancar la nueva versión no tiene conexión a internet y no puede descargarlos).
El caso es que me volví a configurar la conexión a internet y me descargué los drivers, incluido el 88x1.cu pero no me reconoció el adaptador wifi usb ac. Y volví a rendirme, me mantuve en la 7.5.005.
Pero ayer me volvió a picar la curiosidad y decidí intentar las pruebas que me sugerías con la versión 8.0.003
Y, oh sorpresa, no hizo falta hacer ninguna prueba. Por alguna razón que desconozco, el wifi ac (con el driver 88x1.cu) estaba funcionando. Debió ser que cuando lo instalé no reinicié o a saber qué haría mal porque de verdad que yo no vi el adaptador como reconocido, sólo me reconocía el adaptador n.
El caso es que ahora está funcionando perfectamente en la versión 8.0.003. Así que, tres cosas:
Decir que el adaptador wifi ac con driver 88x1.cu ha vuelto a funcionar en la 8.0.003
Pedirte perdón de nuevo por no contestarte en tanto tiempo
Agradecerte infinitamente tu ayuda
Saludos
 
  • Me gusta
Reactions: evox

Tururu

Ensamblado con piezas recicladas y el 17-9-2017 KO
Miembro del equipo
Moderador OpenSPA
Lo primero felicidades @Paquete
Por si por A o por B tienes que pasar otra vez de 7.5.005 a 8.0.00x, recuerda el aviso que tienes en la versión 8.0.00x por importantes cambios.
Si no atiendes este aviso, el deco se puede bloquear.

Es necesario hacer instalación limpia sin usar ningún backup de la configuración.
Instalación limpia es desde cero.

Lo dicho felicidades.
OK-chulo-jpg.gif

.