Home

azbox elite e openspa 4.0 problema com usb

hal2000

Usuario
Amigo OpenSPA
Forero
4 Ago 2021
10
2
0
50
buenos dias a todos, tenho um azbox elite com firmware openspa 4.0, e tenho um problema com pen-usb, nao me funciona nenhuma quer em fat, fat32 ou ex3.
com o comando dmesg da este erro:

[ 204.390000] usb 1-2: new high-speed USB device number 2 using ehci_hcd
[ 204.400000] ehci_hcd 0000:00:02.2: fatal error
[ 204.400000] ehci_hcd 0000:00:02.2: HC died; cleaning up
[ 204.410000] hub 1-0:1.0: cannot reset port 2 (err = -19)
[ 204.420000] hub 1-0:1.0: cannot disable port 2 (err = -19)
[ 204.420000] hub 1-0:1.0: cannot reset port 2 (err = -19)
[ 204.430000] hub 1-0:1.0: cannot disable port 2 (err = -19)

alguem sabe como resolver este erro, com o firm openspa 5.0 acontece o mesmo.
 

evox

OpenSpa Team
Miembro del equipo
Moderador OpenSPA
2 Mar 2009
5.311
3.437
0
Tiene pinta de averia del harware.

Salu2.
 

hal2000

Usuario
Amigo OpenSPA
Forero
4 Ago 2021
10
2
0
50
Tiene pinta de averia del harware.

Salu2.
No el hardware esta ok, com firmware original ou con firmware space 2.2 funciona e consigo montar e ver movies, com firmware openatv 4.0 consigo montar la pen drive mas el media center encrava apos 20s de ver el movie.
no es hardware penso que tiene a ver com drivers del kernel.
 

hal2000

Usuario
Amigo OpenSPA
Forero
4 Ago 2021
10
2
0
50
Buenos dias, encontrei uma soluçao temporaria pro problema:
apos ligar por telnet e executar dmesg da o erro
-->[ 204.400000] ehci_hcd 0000:00:02.2: fatal error
desativar o driver de usb 2.0
--echo -n "0000:00:02.2" > /sys/bus/pci/drivers/ehci_hcd/unbind
caregar o modulo 2.0
--modprobe ehcd_hcd
activar o driver
--echo -n "0000:00:02.2" > /sys/bus/pci/drivers/ehci_hcd/bind

A pen funciona e le os ficheiros, corri um filme sem problemas com o media center e ate consegui instalar o multiboot.
o problema é que é temporario, se desligar e voltar a ligar, o usb deixa de funcionar outra vez.
penso que talvez seja a ordem pela qual o kernel carrega os modulos, vou ler mais um pouco a ver se encontro soluçao definitiva.
Se alguem souber como resolver diga.
gracias.
 
  • Me gusta
Reactions: evox

hal2000

Usuario
Amigo OpenSPA
Forero
4 Ago 2021
10
2
0
50
hola, buenos dias,continuo com o problema das pen usb, fiz um script que tenho na box que executa os comandos referidos e me monta as usb.
a ideia era crear un plugin que excutasse esse script, assim era mais pratico e nao tinha de fazer telnet para executar o script.

alguem sabe como crear un plugin que execute o script, ou sabe onde posso encontar um manual, na area de manual nao tem la nada de como criar um plugin.
gracias.
 

evox

OpenSpa Team
Miembro del equipo
Moderador OpenSPA
2 Mar 2009
5.311
3.437
0
Tienes en plugins Openspa el Script Executer. Lo instalas y metes el script que has hecho en /usr/script y le das permisos 755. Desde menu plugins entras al scritp executer y lanzas tu script las veces que necesites con el mando.

Salu2.