Este sitio es propiedad de cookies de terceros.
Si usted continúa con nosotros, entendemos que acepta nuestro uso de cookies.

  • Este sitio usa cookies. Para continuar usando este sitio, debes aceptar nuestro uso de cookies. Más información.
Home

Avances Jtag y Azbox Elite HD

Asu

Vip
Vip OpenSPA
#1
Veo que hay gente con Azbox Elite HD en Booting, inicio este hilo por si alguno se quiere sumar o unir al estudio de este decodificador, su Jtag y compartir su trabajo.
Después de estar bastante tiempo buscando información por Internet cabe la posibilidad de que este decodificador no tenga el Jtag inhabilitado por firmware y este, este cortado algunos de sus puntos del conector Jtag en la placa. hasta Ahora me habia giado por una imagen sacada de internet donde se veian los puntos de TDI, TDO, etc... directos al procesador pero las pruebas realizadas hasta ahora no habia dado resultado. Asi que me decido a quitar desmontar el procesador de la placa y estos pines del Jtag estan localizados en el procesador sin corte.


TRST_N pin 1 puerto Jtag del decodificador va directo al procesador
TDI pin 3 puerto Jtag del decodificador va directo al procesador
TDO pin5 puerto Jtag del decodificador va directo al procesador
TMS pin 7 puerto Jtag del decodificador va directo al procesador
TCK pin 9 del Jtag del decodificador va directo al procesador
GND pin 2, 4, 6, 8. 10, del puerto Jtag
JTAG_ENABLE jumper J2 en placa, si hacemos puente en este punto también va directo al procesador

Dudas que surgen:
falta por localizar pines 11 y 14 del puerto Jtag.

Animaros y vamos a ver si podemos con este decodificador, el que lo tenga en Booting ya lo tiene muerto por lo que no va a perder nada y puede salvar algún que otro.

Subo una imagen de la placa sin procesador señalando los puntos del puerto Jtag, van directo al procesador

P.D. Hasta ahora nadie con azbox Elite en booting ha compartido ninguna prueba, ni pregunta etc... y solo un par de user con dudas, me pregunto, ¿No hay nadie interesado en este tema? ¿Nadie aportar una idea o alguna sugerencia? con esto no quiero obligar a nada, pero si no somos para nosotros mismo, como vamos a ser para los demás.

Editado 05/05/2014 21:41
 

Adjuntos

Última edición:

Asu

Vip
Vip OpenSPA
#5
Enciendes el decodificador y dejas que coja un poquito de temperatura, desconecta de la corriente y gira de izquierda a derecha el disipador hasta que se quite, también, con mucho cuidado, metes alguna herramienta entre las abertura del disipador para hacer mas fuerza al girar.
 

oscar_fl

Hechado .
Loco por OpenSPA
Forero
#6
Enciendes el decodificador y dejas que coja un poquito de temperatura, desconecta de la corriente y gira de izquierda a derecha el disipador hasta que se quite, también, con mucho cuidado, metes alguna herramienta entre las abertura del disipador para hacer mas fuerza al girar.
Antes de hacer eso seria conveniente pillar algo de silicona térmica para cuando tenga que ponerlo.
 

gtt64

Corazon rojiblanco
Loco por OpenSPA
Amigo OpenSPA
#8
pasta térmica después de quitarlo no servirá de nada tienes que coger una pegatina de duoble cara de material asbesto /asbesto es el nombre común de un grupo de minerales fibrosos, la mayoría de los cuales son silicatos de magnesio /
y una vez poniendo el propio Az en marcha volver a colocar disipador encima de micro ,yo lo hago asi,
o algún silicona térmico que también pega el disipador de aluminio como pegamiento y no permita que se cae cuando hagas movimientos de deco
salu
 

Asu

Vip
Vip OpenSPA
#9
Antes de hacer eso seria conveniente pillar algo de silicona térmica para cuando tenga que ponerlo.
Yo no aconsejaría la silicona térmica, esta, se derrite al coger temperatura y podría moverse el disipador o hacer contacto con alguna otro componente yo aconsegaria lo que trae de fabrica, una buena cinta adhesiva por ambas caras que lo hay en cualquier ferretería.
 

Asu

Vip
Vip OpenSPA
#10
Haber Voy a Compartir una Muy buena Noticia, hoy me mandaron un Azboz Premium+ para sacarlo de Booting, le quito el disipador y vuala tiene Revision C en su procesador y en placa es: PAVO_MAIN_REV 3.00, con lo que el Azbox Elite coge mas fuerza para poder bootearlo por puerto Jtag. Eso si, necesitamos la ayuda de todos, y me referiero a todos lo que tengais decodificadores Azboz, (Elite, Premium, Premium+, etc..) hay que localizar los puntos de Jtag lo mas cercano posible al procesador y compararlos con la palca del Elite.
También tengo que comentar que en el Premium+ ha ocurrido una cosa rara, al activar la consola con Alf+F2 a saltado solo a borrar la flash y programar, lo normal al pulsar Alf+F2 es que salte a la consola y le mande los comando, Halt, Reset, Reset init, etc... y después se ponga a borrar y programar la flash.

Subo unas imagenes del Premium+
 

Adjuntos

Última edición:

jm43

Usuario
Loco por OpenSPA
#11
Una pregunta @Asu, ¿cuanto te mide el cable jtag, desde la placa al conector db25 del pc? Es que lo que me ocurre que se pare cuando conecto alguna luz puede ser por las interferencias que pueda llegar a través del cable
 

Asu

Vip
Vip OpenSPA
#12
Una pregunta @Asu, ¿cuanto te mide el cable jtag, desde la placa al conector db25 del pc? Es que lo que me ocurre que se pare cuando conecto alguna luz puede ser por las interferencias que pueda llegar a través del cable
Unos 25 cm, pero el cable que va al puerto paralelo es algo mas largo que los normales, no creo que eso sea la causa de tu interferencia, casi me atrevo apostar que es de la instalación de tu vivienda.
 

Adjuntos

jm43

Usuario
Loco por OpenSPA
#14
Una cuestión técnica. En el esquema del jtag las resistencias pull-up son de 120 ohmios, pero en el esquema original del sigma son de 10k, ¿alguién sabe si esto es importante?
 

Adjuntos

Asu

Vip
Vip OpenSPA
#15
Una cuestión técnica. En el esquema del jtag las resistencias pull-up son de 120 ohmios, pero en el esquema original del sigma son de 10k, ¿alguién sabe si esto es importante?
El Jtag de patel lleva en esos mismo punto resistencia 2k2 y en los decodificadores Thomson se puenteban para que hubiera mejor comunicacion y en algunos decodificadores si no se puenteban no habia comunicacion, se puede deducir que llevan unos u otros valores en su resistencias dependiendo de la comunicacion que se tenga con su procesador, flash, etc...
 

Adjuntos

jm43

Usuario
Loco por OpenSPA
#17
El Jtag de patel lleva en esos mismo punto resistencia 2k2 y en los decodificadores Thomson se puenteban para que hubiera mejor comunicacion y en algunos decodificadores si no se puenteban no habia comunicacion, se puede deducir que llevan unos u otros valores en su resistencias dependiendo de la comunicacion que se tenga con su procesador, flash, etc...

Voy a realizar este jtag para probar y ya posteare resultados. El tema es que he leído que si en una entrada digital de un micro, como son de alta impedancia, si no se colocan resistencias pull-up o pull-down, los cables pueden actuar como antenas y provocar lecturas erróneas por las interferencias electromagnética a, lo que me pasa cuando apago y enciendo la luz


Enviado desde mi V975m Core4 mediante Tapatalk
 
'Me Gusta': Edu

Asu

Vip
Vip OpenSPA
#18
Montado el Jtag sin el Array de resistencia RP6 y RP7, conectando y desconectado RP1 y RP2

Esta tarde me puse a montar el Jtag en la placa con la información del primer post y si conecto RP1 y RP2 no reconoce el Jtag, si desconecto RP1 (3,3 V) si reconoce el Jtag aunque no hay comunicación con el preocesador. RP2 parece que da igual que este conectado como que no, no se observa ningún cambio.
 

Adjuntos

Última edición:

Edu

Usuario Destacado
Vip OpenSPA
#19
que revision del procesador tienes? mi vecino tiene el elite con revision c, a ver so lo revivimos
 

Edu

Usuario Destacado
Vip OpenSPA
#20

Voy a realizar este jtag para probar y ya posteare resultados. El tema es que he leído que si en una entrada digital de un micro, como son de alta impedancia, si no se colocan resistencias pull-up o pull-down, los cables pueden actuar como antenas y provocar lecturas erróneas por las interferencias electromagnética a, lo que me pasa cuando apago y enciendo la luz


Enviado desde mi V975m Core4 mediante Tapatalk
Como te fue amigo? lograste revivir el azbox
saludos